...

Как посчитать отдельные слова в Excel (с примерами)

Как посчитать отдельные слова в Excel (с примерами) Статьи

Вы можете использовать следующие формулы для подсчета встречаемости определенных слов в Excel:

Метод 1: подсчитать появление определенного слова в ячейке

=(LEN(A2)-LEN(SUBSTITUTE(A2,"слово","")))/LEN("слово")

Эта конкретная формула подсчитывает, сколько раз слово встречается в ячейке A2.

Метод 2: подсчитать появление определенного слова в диапазоне

=СУММПРОИЗВ((LEN(A2:A8)-LEN(SUBSTITUTE(A2:A8,"слово","")))/LEN("слово"))

Эта конкретная формула подсчитывает, сколько раз слово встречается в диапазоне ячеек A2:A8.

В следующих примерах показано, как на практике использовать каждую формулу со следующим столбцом текста в Excel:

Как посчитать отдельные слова в Excel (с примерами)

Пример 1. Подсчет появления определенного слова в ячейке

Мы можем ввести следующую формулу в ячейку B2, чтобы подсчитать, сколько раз слово «Три» встречается в ячейке A2:

=(LEN(A2)-LEN(SUBSTITUTE(A2,"Три","")))/LEN("Три")

Затем мы можем перетащить и заполнить эту формулу до каждой оставшейся ячейки в столбце B:

Как посчитать отдельные слова в Excel (с примерами)

В столбце B показано, сколько раз слово «Три» появилось в соответствующей ячейке столбца A.

Примечание. В этой формуле учитывается регистр. Например, слово «три» не будет засчитано.

Пример 2. Подсчет появления определенного слова в диапазоне

Мы можем ввести следующую формулу в ячейку B10, чтобы подсчитать, сколько раз слово «Три» встречается в диапазоне ячеек A2:A8:

=СУММПРОИЗВ((LEN(A2:A8)-LEN(SUBSTITUTE(A2:A8,"Три","")))/LEN("Три"))

На следующем снимке экрана показано, как использовать эту формулу на практике:

Как посчитать отдельные слова в Excel (с примерами)

Мы видим, что слово «Три» встречается в общей сложности 6 раз в диапазоне ячеек A2:A8.

Чтобы создать формулу без учета регистра, мы можем использовать функцию UPPER в Excel следующим образом:

=СУММПРОИЗВ((LEN(A2:A8)-LEN(ЗАСТАВИТЬ(UPPER(A2:A8),UPPER("Три"),"")))/LEN("Три") )

Мы можем ввести эту формулу в ячейку B10, чтобы подсчитать, сколько раз «Три» (независимо от регистра) встречается в диапазоне ячеек A2:A8.

Как посчитать отдельные слова в Excel (с примерами)

Мы видим, что слово «Три» (независимо от регистра) встречается всего 8 раз в диапазоне ячеек A2:A8.

Оцените статью
Mir-Tehnologiy
Добавить комментарий

  1. Глеб

    Почему Excel не может посчитать отдельные слова? Потому что он считает только числа и формулы, а не слова!

    Ответить