Функция суммеслимн в excel – примеры применения

Помимо текстового редактора Word, Microsoft Office имеет в своем арсенале мощную программу, для работы с таблицами, макросами и базами данных – Excel. Эксель позволяет работать с массивами информации, делать отборы по заданным условиям, а также проводить различные математические операции со значениями в ячейках. Одним из таких операторов является функция суммеслимн в excel, примеры использования которой рассмотрим в этой статье.

Структура функции

Прежде чем рассматривать механизм работы оператора, необходимо ознакомится с содержанием функции, а также синтаксисом формулы. Суммеслимн расшифровывается как сумма данных, если выполняется множество.

Структура функции

Значения аргументов следующие:

  1. В диапазон суммирования записываете столбец или строку, по которой будет вычисляться сумма значений.
  2. Диапазон условия 1 нужен для задания массива, в котором будут применены параметры отбора данных.
  3. Условие 1 является дополнением к предыдущему аргументу. На этой позиции указывается критерий отбора в диапазоне условия 1.
  4. Затем идут дополнительные аргументы, с помощью которых можно уточнить параметры расчета суммы значений.

Важно! Количество ячеек диапазона суммирования и условия должно быть одинаковым.

Примеры суммеслимн

Для начала создаете таблицу со значениями. Можно использовать различные форматы ячеек и в зависимости от этого будет меняться синтаксис внутри формулы. Для примера будем работать с таблицей следующего вида:

Примеры суммеслимн

Как видите, ячейки содержат и даты, и текст, и цифры. Будем задавать критерии для поиска суммы, а также рассматривать структуру оператора под поставленную задачу.

  1. Примеры с датами продаж:

Задача: найти количество продуктов проданных 22.02.2019г.

В свободной ячейке пишете следующее: =СУММЕСЛИМН(С2:С8;B2:B8;B2)

Задача

  1. Примеры с двумя условиями:

Задача: определить сумму яблок, проданных 22.02.2019г.:

Функция будет выглядеть следующим образом: =СУММЕСЛИМН(C2:C8;B2:B8;B2;A2:A8;»Яблоко»)

Определить сумму яблок

где B2:B8;B2 – первое условие, а A2:A8;»Яблоко» – второе. Диапазон суммирования по столбцу Количество.

Важно! Все текстовые блоки внутри формулы записываются в двойных кавычках. 

  1. Примеры с текстом и звездочкой:

Задача: найти количество яблок, проданных Артемом.

Содержимое пустой ячейки: =СУММЕСЛИМН(C2:C8;A2:A8;»Яблоко»;D2:D8;»А*»)

Найти количество яблок, проданных Артемом

Использование подстановочного знака звездочка помогает искать продавца, имя которого начинается на букву А. При таком условии считается число яблок, проданных Артемом и Ангелиной, поскольку их имена начинаются на букву А. Чтобы найти именно продажи Артема, необходимо изменить аргумент на «Ар*».

Использование подстановочного знака звездочка

  1. Также в числовых столбцах можно использовать операторы сравнения. Если в условие больше меньше или равно, то можно обозначить границы поиска по цифрам.

Задача: Найти дату продажи Ангелиной продуктов больше 10 единиц.

Функция имеет следующий вид: =СУММЕСЛИМН(B2:B8;D2:D8;»Ангелина»;C2:C8;»>10″)

Найти дату продажи Ангелиной продуктов

Как видите, оператор СУММЕСЛИМН позволяет находить сумму значений исходя из нескольких параметров, выполнение которых обязательно. При этом нужно соблюдать правила одинаковости размера массивов и написания текстовых блоков. Единственным недостатком такой функции является то, что нельзя суммировать несколько диапазонов. Для этого лучше использовать СУММПРОИЗВ.

Жми «Нравится» и получай только лучшие посты в Facebook ↓

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: