Функция индекс в excel – примеры использования

Microsoft Office Excel имеет в своем арсенале формулу, которая позволяет определять координаты ячейки и возвращать ее значение в любую точку на рабочем листе. Такая опция полезна при работе с объемными базами данных, содержащих большое количество информации. Сегодня разберемся, как работает функция индекс в excel.

Описание

Чтобы детально разобрать принцип работы инструмента, необходимо создать массив данных, например количество потребляемых калорий за день в течение недели:

Функция индекс в excel 1

Необходимо узнать, сколько калорий должен содержать ланч в пятницу. Порядок использования функции ИНДЕКС следующий:

  1. Выбираете произвольную ячейку для отображения результата.
  2. В строке формул записываете =ИНДЕКС(B2:E8;5;3)

Функция индекс в excel 2

где B2:E8 — диапазон значений, внутри которого необходимо найти требуемую позицию. Два последующих числа обозначают номер строки и столбца соответственно.

Важно! Начало отсчета номеров осуществляется в рамках выделенного диапазона, при этом заголовки сверху и слева не учитываются.

  1. Результат формулы соответствует значению в таблице, значит все сделано правильно.

Функция индекс в excel 3

Данная пошаговая инструкция подойдет как для чайников, так и для более уверенных пользователей редактора. Использование функции ИНДЕКС не вызывает особых затруднений.

Примеры

Рассмотрим примеры с несколькими условиями. Например, необходимо найти количество продаж стульев в третьем магазине. Исходные данные выглядят следующим образом:

Функция индекс в excel 4

Запишем формулу, при этом блок диапазонов записывается через точку с запятой и заключается в круглые скобки. Далее указываете номера строки, столбца и диапазона для поиска.

На заметку! Для каждого отдельного массива нумерация начинается с единицы, без учета заголовков.

Функция индекс в excel 5

Чтобы понять к чему относится полученный результат, в отдельной ячейке снова запишем ИНДЕКС, но уже с применением функции поискпоз, которая возвращает числовое значение позиции в массиве данных.

Функция индекс в excel 6

Как видите, использования инструмента ИНДЕКС не вызывает особых сложностей. Однако в сочетании с другими формулами возможности функции расширяются, что позволяет решать более трудные задачи.

Жми «Нравится» и получай только лучшие посты в Facebook ↓

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: