...

Excel: как извлечь первое слово из ячейки с примером

Excel: как извлечь первое слово из ячейки Excel

Вы можете использовать следующую формулу для извлечения первого слова из ячейки в Excel:

=ЕСЛИОШИБКА(TEXTBEFORE(A2, " "), A2)

Эта конкретная формула извлекает первое слово из ячейки A2.

В следующем примере показано, как использовать эту формулу на практике.

Пример: как извлечь первое слово в Excel

Предположим, у нас есть следующий столбец строк в Excel:

Excel: как извлечь первое слово из ячейки с примером

Предположим, мы хотим извлечь первое слово из каждой ячейки столбца A.

Для этого мы можем ввести следующую формулу в ячейку B2:

=ЕСЛИОШИБКА(TEXTBEFORE(A2, " "), A2)

Затем мы можем нажать и перетащить эту формулу вниз к каждой оставшейся ячейке в столбце B:

Excel извлечь первое слово из ячейки

Столбец B теперь содержит первое слово из каждой соответствующей ячейки в столбце A.

Например:

Формула извлекает My из Мое любимое животное — ламантин.

Формула извлекает Это из Это отличный день Формула извлекает Мы из Нам следует повеселиться.

И так далее.

Как работает эта формула

Функция TEXTBEFORE в Excel извлекает весь текст в ячейке перед определенным символом или подстрокой.

Эта функция использует следующий синтаксис:

TEXTBEFORE(текст, разделитель, [instance_num], [match_mode], [match_end], [if_not_found])

где:

  • текст: текст для поиска.
  • разделитель: символ или подстрока для извлечения текста перед
  • instance_num (необязательно): экземпляр разделителя, перед которым необходимо извлечь текст (по умолчанию — 1).
  • match_mode (необязательно): 0 = с учетом регистра (по умолчанию), 1 = без учета регистра
  • match_end (необязательно): считать конец текста разделителем (по умолчанию отключено).
  • if_not_found (необязательно): значение, возвращаемое, если разделитель не найден.

Напомним, что мы использовали следующий синтаксис для извлечения первого слова из ячейки A2:

=ЕСЛИОШИБКА(TEXTBEFORE(A2, " "), A2)

Сначала мы используем функцию TEXTBEFORE, чтобы извлечь весь текст перед первым пробелом в ячейке A2.

Эта функция вернет ошибку, если в ячейке есть только одно слово, поэтому мы используем функцию ЕСЛИОШИБКА, чтобы указать, что мы должны возвращать весь текст в ячейке, если есть только одно слово.

Конечным результатом является то, что мы можем извлечь первое слово из ячейки.

Оцените статью
Mir-Tehnologiy
Добавить комментарий

  1. Анастасия

    «О, Excel, ты такой умный, как извлечь первое слово из ячейки? Вот это действительно сложная задача для нас, людей, которые считают себя гуру Excel. У меня даже нет слов, чтобы описать, насколько впечатляюще это знание!»

    Ответить
  2. Schy

    «В Excel слово — ключ к информации, извлеки его первым делом!»

    Ответить